Etienne BAUDOUX

Forum sur les projets de Etienne BAUDOUX


Message d'ereur perte d'images[RESOLU]

BadGamer
BadGamer
On commence à connaître
On commence à connaître

Masculin Nombre de messages : 153
Date d'inscription : 29/09/2010

Message d'ereur perte d'images[RESOLU] Empty Message d'ereur perte d'images[RESOLU]

Message par BadGamer le Mar 7 Déc 2010 - 16:39

Lorsque je sauvegarde mon projet, que je le quitte, que je le relance, j'ai ce message d’erreur : Message d'ereur perte d'images[RESOLU] Errueu10

Mes images utilisées sont dans le meme repertoire que le projet.
Que faire ? ^^
Merci d'avance


Dernière édition par BadGamer le Mer 8 Déc 2010 - 15:10, édité 1 fois
Admin
Admin
Administrateur
Administrateur

Masculin Nombre de messages : 1882
Age : 27
Localisation : Boulogne Billancourt(92100)(France)
Emploi/loisirs : Software Development Engineer
Date d'inscription : 24/01/2008

Message d'ereur perte d'images[RESOLU] Empty Re: Message d'ereur perte d'images[RESOLU]

Message par Admin le Mar 7 Déc 2010 - 16:51

Passer par les ressources du projet. En fait, c'est un problème assez courant depuis SZ 1.0. "Certaines" images placés dans "certains" contrôle rencontres des problèmes avec le concepteur de fenêtre (surtout pour les ToolStrip, MenuStrip et autre).
Une alternative : passer par les ressources du projet.
Va dans les paramètres du projet, onglet Ressources, et ajoute les ressources de ton choix, et enregistre.
Puis, dans ton fichier, créer une fonction lié à l'évènement Load de la fenêtre (afin qu'elle s'exécute lorsque la fenêtre s'ouvre), et là, change les propriétés .Image des contrôles pour leur donné la fameuse image. Pour cela :
Utilise l'action "Modifier une propriété d'un contrôle". Sélectionnes ton contrôle, la propriété .Image, et met en valeur "%(". Là, un popup s'ouvre, et te permet de sélectionner une ressource. Décoche "cette valeur est du texte", et valide.

Répète la manoeuvre pour chaque contrôles Wink

@+



Les 4 règles d'or du forum : Bonjour, Merci, Pas de SMS, Et un petit "[RESOLU]" dans le titre du sujet quand le problème est réglé. Wink

Etienne

Site internet : http://www.velersoftware.com
Twitter : http://twitter.com/VelerSoftware
BadGamer
BadGamer
On commence à connaître
On commence à connaître

Masculin Nombre de messages : 153
Date d'inscription : 29/09/2010

Message d'ereur perte d'images[RESOLU] Empty Re: Message d'ereur perte d'images[RESOLU]

Message par BadGamer le Mar 7 Déc 2010 - 18:59

Merci mais lors de la dernierere étape, dans la pop up je n'est pas mes images mais seulement mes variables...
Je sélectionne bien . Image.System Drawing Image ? Puis lorsque je fait %( la pop up s 'ouvre avec mes variables: 3 onglets: variables du projet, variables d'application et variables d’environnement mais pas mes images...
Comment faire ? ^^
Admin
Admin
Administrateur
Administrateur

Masculin Nombre de messages : 1882
Age : 27
Localisation : Boulogne Billancourt(92100)(France)
Emploi/loisirs : Software Development Engineer
Date d'inscription : 24/01/2008

Message d'ereur perte d'images[RESOLU] Empty Re: Message d'ereur perte d'images[RESOLU]

Message par Admin le Mar 7 Déc 2010 - 20:19

Petit exemple Wink :

Message d'ereur perte d'images[RESOLU] Sans_t21



Les 4 règles d'or du forum : Bonjour, Merci, Pas de SMS, Et un petit "[RESOLU]" dans le titre du sujet quand le problème est réglé. Wink

Etienne

Site internet : http://www.velersoftware.com
Twitter : http://twitter.com/VelerSoftware
Tinei
Tinei
On s'intègre
On s'intègre

Masculin Nombre de messages : 209
Age : 21
Localisation : Sur la terre....Où peut être sur une autre planète XD
Emploi/loisirs : Réfléchissez un peu, et vous trouverez
Humeur : Très bonne
Date d'inscription : 05/11/2010

Message d'ereur perte d'images[RESOLU] Empty Re: Message d'ereur perte d'images[RESOLU]

Message par Tinei le Mer 8 Déc 2010 - 12:25

@BadGamer a écrit:Lorsque je sauvegarde mon projet, que je le quitte, que je le relance, j'ai ce message d’erreur : Message d'ereur perte d'images[RESOLU] Errueu10

Mes images utilisées sont dans le meme repertoire que le projet.
Que faire ? ^^
Merci d'avance

J'ai exactement la même chose !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!



Cordialement, Tinei

_____________________________________________________________
Toinousoft
La rapidité et l'assistance


Site internet: http://tinei.olympe-network.com/toinousoft/index.html
Forum: http://toinousoft-site.frbb.net/forum
BadGamer
BadGamer
On commence à connaître
On commence à connaître

Masculin Nombre de messages : 153
Date d'inscription : 29/09/2010

Message d'ereur perte d'images[RESOLU] Empty Re: Message d'ereur perte d'images[RESOLU]

Message par BadGamer le Mer 8 Déc 2010 - 12:50

@Admin a écrit:Petit exemple Wink :

Message d'ereur perte d'images[RESOLU] Sans_t21
Ah ok en fait j'avai juste pas sauevagrde amusé mais maintenant nouveau probleme : Message d'ereur perte d'images[RESOLU] Ereur10

Sur les 3 images que je veut utiliser, deux me renvoi cette erreur alors que j'ai fait la meme chose, seul leurs noms changent --'
Admin
Admin
Administrateur
Administrateur

Masculin Nombre de messages : 1882
Age : 27
Localisation : Boulogne Billancourt(92100)(France)
Emploi/loisirs : Software Development Engineer
Date d'inscription : 24/01/2008

Message d'ereur perte d'images[RESOLU] Empty Re: Message d'ereur perte d'images[RESOLU]

Message par Admin le Mer 8 Déc 2010 - 12:52

Leur nom n'est-il pas "PictureBox" et "Button" par hasard? C'est peut-être d'ailleurs pour ça que tu as eu un problème à la base ^^



Les 4 règles d'or du forum : Bonjour, Merci, Pas de SMS, Et un petit "[RESOLU]" dans le titre du sujet quand le problème est réglé. Wink

Etienne

Site internet : http://www.velersoftware.com
Twitter : http://twitter.com/VelerSoftware
BadGamer
BadGamer
On commence à connaître
On commence à connaître

Masculin Nombre de messages : 153
Date d'inscription : 29/09/2010

Message d'ereur perte d'images[RESOLU] Empty Re: Message d'ereur perte d'images[RESOLU]

Message par BadGamer le Mer 8 Déc 2010 - 12:55

non leur nom est cadre et login mais je les ai renommé en c et l et sa marche --' je ne comprend pas mais ca marche c'est l'essentielle ^^
Admin
Admin
Administrateur
Administrateur

Masculin Nombre de messages : 1882
Age : 27
Localisation : Boulogne Billancourt(92100)(France)
Emploi/loisirs : Software Development Engineer
Date d'inscription : 24/01/2008

Message d'ereur perte d'images[RESOLU] Empty Re: Message d'ereur perte d'images[RESOLU]

Message par Admin le Mer 8 Déc 2010 - 13:02

Ah, alors voici mon hypothèse, lol! :

Tu avais un contrôle nommé "login" et une ressource également nommé "login". D'un côté tu as raison, c'est un reflexe que l'on a facilement pour la simple raison que comme ça on sait facilement quoi est lié à quoi amusé. Le problème qu'il y avait est juste que l'ordinateur (pas SZ, mais ça revient au même lol) a confondu le contrôle "login" avec l'image "login", donc évidemment ça pose problème. Razz

C'est un problème souvent rencontré sur le forum, il faudrait vraiment que je trouve une solution pour éviter ce problème Rolling Eyes

@+



Les 4 règles d'or du forum : Bonjour, Merci, Pas de SMS, Et un petit "[RESOLU]" dans le titre du sujet quand le problème est réglé. Wink

Etienne

Site internet : http://www.velersoftware.com
Twitter : http://twitter.com/VelerSoftware
BadGamer
BadGamer
On commence à connaître
On commence à connaître

Masculin Nombre de messages : 153
Date d'inscription : 29/09/2010

Message d'ereur perte d'images[RESOLU] Empty Re: Message d'ereur perte d'images[RESOLU]

Message par BadGamer le Mer 8 Déc 2010 - 13:07

@Admin a écrit:Ah, alors voici mon hypothèse, lol! :

Tu avais un contrôle nommé "login" et une ressource également nommé "login". D'un côté tu as raison, c'est un reflexe que l'on a facilement pour la simple raison que comme ça on sait facilement quoi est lié à quoi amusé. Le problème qu'il y avait est juste que l'ordinateur (pas SZ, mais ça revient au même lol) a confondu le contrôle "login" avec l'image "login", donc évidemment ça pose problème. Razz

C'est un problème souvent rencontré sur le forum, il faudrait vraiment que je trouve une solution pour éviter ce problème Rolling Eyes

@+
Vous pourriez peut etre nommer toute les ressources par exemple : je rentre la ressource login et sa enregistre en Rlogin , pour les images : login ==> Ilogin enfin je ne sait pas amusé
Et sinon ce n'a pas de raport avec le premier message mais je demande quand meme n'hesitez pas a dire si vous voulez que poste un nouveau sujet alors voila : comment recuperer le nombre de caracteres d'une variable, j'aimerai mettre : prenom ( si prenom >15 alors marquer erreur) en fait si l'utilisateur marque : bonjour je m'apelle Jean Pierre et ba je fais une erreur pour ne pas qu lorsque je souhaite utiliser cette variable cela dépasse de mes fenetrer amusé Estce possible ?
lereparateurdepc
lereparateurdepc


Masculin Nombre de messages : 5606
Age : 27
Localisation : Calvados
Emploi/loisirs : Electrotechnicien / électricité, HAUTE TENSION, électronique, informatique, automatisme , Arduino, bref le BRICOLAGE , ...
Humeur : toujours cool
Date d'inscription : 31/01/2010

Message d'ereur perte d'images[RESOLU] Empty Re: Message d'ereur perte d'images[RESOLU]

Message par lereparateurdepc le Mer 8 Déc 2010 - 15:52

re ,

Moi , pour mes variables , en général , je met : " var_ " puis la variable !
Pour une ressources : " file_" puis le nom du fichier !Smile

Cordialement ,
Le réparateurde PC



Modérateur & Administrateur du forum
Merci de contacter les membres par MP ou mail que pour "urgences". Le forum est fait pour ça. Merci

@ Contact : franleboss@gmail.com  Smile
Arrow  Visitez mon site : désolé l'hébergeur à fermé Sad

Ma chaine tutube : https://www.youtube.com/channel/UC7iU59NNAHz-tW5wqcgONHA



Contenu sponsorisé

Message d'ereur perte d'images[RESOLU] Empty Re: Message d'ereur perte d'images[RESOLU]

Message par Contenu sponsorisé


    La date/heure actuelle est Ven 22 Nov 2019 - 8:41