Etienne BAUDOUX

Forum sur les projets de Etienne BAUDOUX


[résolu]Problème a l'ouverture d'un projet

Partagez
avatar
polien


Masculin Nombre de messages : 2893
Age : 21
Localisation : Bouches du Rhones
Emploi/loisirs : velo, informatique, électronique, robotique, modélisme feroviaire
Humeur : Je commence tout mais ne finit rien :P
Date d'inscription : 19/05/2011

Re: [résolu]Problème a l'ouverture d'un projet

Message par polien le Mer 28 Oct 2015 - 11:29

Bonjour,

D'après ce que j'ai pu observé, ce phénomène se produit quand les fenêtres ne s'ouvrent  pas automatiquement. Pour être plus explicite, quand on modifie un projet avec SZ et que l'on le sauvegarde, toutes les fenêtres déjà ouvertes sont sauvegardé et SZ ouvrira les mêmes fenêtres au prochain démarrage du projet.

Il suffit d'aller voir le fichier du projet (.szproj) situé dans Mes documents / Mes projets SZ / Ma Solution / Mon projet / Mon projet.szproj (chez moi C:\Users\JN\Documents\Mes Projets SoftwareZator\Solution1\Fenêtre_vierge1\Fenêtre_vierge1.szproj ) et d'éditez ce fichier (clic droit, ouvrir avec bloc note).

On obtient quelque chose comme ceci :


Tu sauvegarde au même emplacement que l'original en l'enregistrant par dessus, tu ré-ouvre le fichier de la solution et normalement ça devrai être bon Wink

PS: cette manipulation n'est à faire qu'une fois par projet Wink

avatar
lereparateurdepc


Masculin Nombre de messages : 5541
Age : 25
Localisation : Calvados
Emploi/loisirs : Electrotechnicien / électricité, HAUTE TENSION, électronique, informatique, automatisme , Arduino, bref le BRICOLAGE , ...
Humeur : toujours cool
Date d'inscription : 31/01/2010

Re: [résolu]Problème a l'ouverture d'un projet

Message par lereparateurdepc le Mer 28 Oct 2015 - 17:26

re,

AHH tien je ne savais pas Smile

Merci m'sieur Smile

Cordialement,
Le réparateur de PC



Modérateur & Administrateur du forum
Merci de contacter les membres par MP ou mail que pour "urgences". Le forum est fait pour ça. Merci

@ Contact : franleboss@gmail.com  Smile
Arrow  Visitez mon site : désolé l'hébergeur à fermé Sad

Ma chaine tutube : https://www.youtube.com/channel/UC7iU59NNAHz-tW5wqcgONHA


avatar
uhu7610
Nouveau
Nouveau

Masculin Nombre de messages : 21
Date d'inscription : 21/10/2015

Re: [résolu]Problème a l'ouverture d'un projet

Message par uhu7610 le Mer 28 Oct 2015 - 18:42

Toujours le problème 

avatar
polien


Masculin Nombre de messages : 2893
Age : 21
Localisation : Bouches du Rhones
Emploi/loisirs : velo, informatique, électronique, robotique, modélisme feroviaire
Humeur : Je commence tout mais ne finit rien :P
Date d'inscription : 19/05/2011

Re: [résolu]Problème a l'ouverture d'un projet

Message par polien le Mer 28 Oct 2015 - 23:23

re,

@lereparateurdepc: de rien... c'est en essayant que j'ai remarqué amusé

@uhu7610: Il ne faut pas copier la ligne :
Code:
<FormStart value="WindowsForm1.szw" />

Mais rajouter la ligne :
Code:
<Open name="LeNom" />

Et remplacer LeNom par la valeur (propriété value) de formstart (ici WindowsForm1.szw dans l'exemple).

avatar
uhu7610
Nouveau
Nouveau

Masculin Nombre de messages : 21
Date d'inscription : 21/10/2015

Re: [résolu]Problème a l'ouverture d'un projet

Message par uhu7610 le Jeu 29 Oct 2015 - 13:38

C'est bon ça fonctionne, un grand merci à vous deux qui aident avec excellence la communauté de ce logiciel !

Bonne continuation dans vos différents projets.
avatar
polien


Masculin Nombre de messages : 2893
Age : 21
Localisation : Bouches du Rhones
Emploi/loisirs : velo, informatique, électronique, robotique, modélisme feroviaire
Humeur : Je commence tout mais ne finit rien :P
Date d'inscription : 19/05/2011

Re: [résolu]Problème a l'ouverture d'un projet

Message par polien le Jeu 29 Oct 2015 - 16:26

Merci et de rien amusé

avatar
dell man
On s'intègre
On s'intègre

Masculin Nombre de messages : 259
Age : 21
Localisation : Marseille
Emploi/loisirs : L'informatique, la créativité, tout ce qui fait plaisir quoi :)
Date d'inscription : 23/10/2011

Re: [résolu]Problème a l'ouverture d'un projet

Message par dell man le Mar 28 Mar 2017 - 21:40

bonsoir
moi aussi j'ai le meme probleme....mais je n'ai pas du tt compris la solution.....
pourrait on m'aider svp??
ps : version 3.0.0.3

merci bcp



Cordialement,

Dell Man
avatar
lereparateurdepc


Masculin Nombre de messages : 5541
Age : 25
Localisation : Calvados
Emploi/loisirs : Electrotechnicien / électricité, HAUTE TENSION, électronique, informatique, automatisme , Arduino, bref le BRICOLAGE , ...
Humeur : toujours cool
Date d'inscription : 31/01/2010

Re: [résolu]Problème a l'ouverture d'un projet

Message par lereparateurdepc le Mer 29 Mar 2017 - 15:43

re,

[erreur]STP, attention au déterrage......[/erreur]

Je n'ai pas relus l'article mais il parle de SZ 2014.

Ce bug est causé par une MAJ car auparavant, mon SZ 2014 fonctionnais super bien sur mon Win7 x64. Je suis malheureusement incapable de trouver cette MAJ Sad Sad Sad

Cordialement,
Le réparateur de PC



Modérateur & Administrateur du forum
Merci de contacter les membres par MP ou mail que pour "urgences". Le forum est fait pour ça. Merci

@ Contact : franleboss@gmail.com  Smile
Arrow  Visitez mon site : désolé l'hébergeur à fermé Sad

Ma chaine tutube : https://www.youtube.com/channel/UC7iU59NNAHz-tW5wqcgONHA


avatar
polien


Masculin Nombre de messages : 2893
Age : 21
Localisation : Bouches du Rhones
Emploi/loisirs : velo, informatique, électronique, robotique, modélisme feroviaire
Humeur : Je commence tout mais ne finit rien :P
Date d'inscription : 19/05/2011

Re: [résolu]Problème a l'ouverture d'un projet

Message par polien le Mer 29 Mar 2017 - 20:28

@dell man a écrit:bonsoir
moi aussi j'ai le meme probleme....mais je n'ai pas du tt compris la solution.....
pourrait on m'aider svp??
ps : version 3.0.0.3

merci bcp
re,

Yep mon astuce parle de SZ2014, mais il est possible que ça aide pour des soucis avec SZ2012: j'ai pas essayé amusé
Il va falloir éditer le fichier qu'a généré SZ lors de la création de ton projet. Si ton projet s'appelle "Mon projet", le fichier à éditer sera dans Mes documents / Mes projets SZ / Ma Solution / Mon projet / Mon projet.szproj

Tu ouvre ce fichier avec un bloc note, notepad++, sublime text ou autre...



dans l'exemple, après
Code:
<ShouldCompile value="True" />
il faut rajouter la ligne
Code:
<Open name=WindowsForm1.szw" />

Mais cette dernière ligne doit avoir le nom de ton projet à toi, il faut donc que tu recopie le nom de ton projet qui est indiqué sur la ligne
Code:
<FormStart value="WindowsForm1.szw" />
ici, le nom du projet est WindowsForm1.szw

Il faudra donc que tu mette (dans l'exemple)
Code:
<Open name="WindowsForm1.szw" />


Contenu sponsorisé

Re: [résolu]Problème a l'ouverture d'un projet

Message par Contenu sponsorisé


    La date/heure actuelle est Mer 17 Jan 2018 - 1:05