Etienne BAUDOUX

Forum sur les projets de Etienne BAUDOUX


Problème dans l'éditeur de SZ 2012 [RESOLU]

Partagez
avatar
Blackorion35
Je suis là tous les jours
Je suis là tous les jours

Masculin Nombre de messages : 2558
Age : 26
Localisation : Rouen
Emploi/loisirs : Dirigeant société informatique déclaré/Informaticien au CNED
Humeur : En forme !
Date d'inscription : 19/03/2013

Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par Blackorion35 le Ven 29 Nov 2013 - 22:27

Bonsoir,

Depuis quelques jours lorsque je veux ouvrir SZ 2012 Edition Professionnel j'ai un soucis : 

Ce message s'affiche à chaque chargement de n'importe quel projet : 



Je précise que j'ai essayé les solutions suivantes : 

- Réparation de SZ
- Désinstallation puis réinstallation de SZ
- Réinstallation complète du .NET 4.0
- Suppression de toutes les clés du registre liés à SZ 2012 et réinstallation par la suite de SZ 2012 Pro
- Réparation des clés endommagés possibles dans le registre

Et j'ai toujours cette erreur là Sad De plus avant j'avais l'erreur suivante : "impossible d'utiliser cette fonction car l'objet est en cours d'utilisation" (ou un truc s'y rapprochant)... Shocked 

Du coups je me demande comment réinstaller SZ 2012 sans ce soucis si quelqu'un a une idée sa m'aiderai beaucoup Smile 



Merci d'avance à tous et bonne soirée Wink


Dernière édition par Blackorion35 le Mar 3 Déc 2013 - 0:18, édité 1 fois



Le site officiel de notre société : http://algostep-company.fr
Notre WebOS "Rynna" en développement : http://rynnawebos.fr/login
Le WebOS "Zator" conçu pour le forum et ses membres dispo en test ici :
http://algostep-company.fr/WebOS-Zator-Test1/
---------------------------------------------------------
avatar
lereparateurdepc


Masculin Nombre de messages : 5503
Age : 24
Localisation : Calvados
Emploi/loisirs : Electrotechnicien / électricité, HAUTE TENSION, électronique, informatique, automatisme , Arduino, bref le BRICOLAGE , ...
Humeur : toujours cool
Date d'inscription : 31/01/2010

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par lereparateurdepc le Sam 30 Nov 2013 - 7:22

re,

Quand tu as réinstallé SZ, as-tu supprimé le dossier d'install avent de réinstaller SZ ?

Je ne pense pas que cette erreur soit liée au Framework.

As-tu essayé avec un projet vierge ( en gros un nouveau projet) ?

Cordialement,
Le réparateur de PC



Modérateur & Administrateur du forum
Merci de contacter les membres par MP ou mail que pour "urgences". Le forum est fait pour ça. Merci

@ Contact : franleboss@gmail.com  Smile
Arrow  Visitez mon site : désolé l'hébergeur à fermé Sad

Ma chaine tutube : https://www.youtube.com/channel/UC7iU59NNAHz-tW5wqcgONHA


avatar
fandeonepiece2
Je suis là tous les jours
Je suis là tous les jours

Masculin Nombre de messages : 1804
Age : 16
Localisation : chez moi
Emploi/loisirs : Programmation H24
Humeur : massacrante... si je n'ai pas ma dose journalière de programmation
Date d'inscription : 14/09/2013

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par fandeonepiece2 le Sam 30 Nov 2013 - 8:01

bonjour,
j'ai deja eu des messages similaires, dans mes souvenir je faisait un clique droit sur l'onglet d'une fenêtre (par exemple Denoyautage.szw ) et je cliquait sur fermer puis avec l'explorateur de je faisais clique droit ouvrir. essaye toujours mais je ne suis pas sur que ce soit le même message.
cordialement

(désolé pour mon absence)



(ಠ_ಠ)


http://openclassrooms.com/forum/sujet/regie-publicitaire-drozor
avatar
Blackorion35
Je suis là tous les jours
Je suis là tous les jours

Masculin Nombre de messages : 2558
Age : 26
Localisation : Rouen
Emploi/loisirs : Dirigeant société informatique déclaré/Informaticien au CNED
Humeur : En forme !
Date d'inscription : 19/03/2013

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par Blackorion35 le Sam 30 Nov 2013 - 10:12

Bonjour et merci d'avoir répondu Smile 

Oui j'ai fait cela aussi (dossier install) : 

Quand j'ai ce message je clique après dans "Editeur de fonction" et voilà ce qui s'affiche : 

System.Windows.Markup.XamlParseException: La définition de connectionId a levé une exception. ---> System.InvalidCastException: Impossible d'effectuer un cast d'un objet de type 'System.Windows.Input.CommandBinding' en type 'System.Activities.Presentation.View.DesignerView'.
à System.Activities.Presentation.View.DesignerView.System.Windows.Markup.IComponentConnector.Connect(Int32 connectionId, Object target)
à MS.Internal.Xaml.Runtime.ClrObjectRuntime.SetConnectionId(Object root, Int32 connectionId, Object instance)
--- Fin de la trace de la pile d'exception interne ---
à System.Windows.Markup.WpfXamlLoader.Load(XamlReader xamlReader, IXamlObjectWriterFactory writerFactory, Boolean skipJournaledProperties, Object rootObject, XamlObjectWriterSettings settings, Uri baseUri)
à System.Windows.Markup.WpfXamlLoader.LoadBaml(XamlReader xamlReader, Boolean skipJournaledProperties, Object rootObject, XamlAccessLevel accessLevel, Uri baseUri)
à System.Windows.Markup.XamlReader.LoadBaml(Stream stream, ParserContext parserContext, Object parent, Boolean closeStream)
à System.Windows.Application.LoadComponent(Object component, Uri resourceLocator)
à System.Activities.Presentation.View.DesignerView..ctor(EditingContext context)
à System.Activities.Presentation.View.WorkflowViewManager.Initialize(EditingContext context)
à System.Activities.Presentation.WorkflowDesigner.GetViewManager(ModelItem modelItem)
à System.Activities.Presentation.WorkflowDesigner.Load(Object instance)
à System.Activities.Presentation.WorkflowDesigner.Load()
Voici la capture : 




Doit y avoir un lien avec "Workflow Designer" mais je sais pas si cela viens du framework ou de SZ Sad Faudrait voir ça avec Etienne si il reconnait cette erreur Neutral


@lereparateurdepc a écrit:

As-tu essayé avec un projet vierge ( en gros un nouveau projet) ?
Yes : c'est justement le cas sur la capture Wink



Le site officiel de notre société : http://algostep-company.fr
Notre WebOS "Rynna" en développement : http://rynnawebos.fr/login
Le WebOS "Zator" conçu pour le forum et ses membres dispo en test ici :
http://algostep-company.fr/WebOS-Zator-Test1/
---------------------------------------------------------
avatar
lereparateurdepc


Masculin Nombre de messages : 5503
Age : 24
Localisation : Calvados
Emploi/loisirs : Electrotechnicien / électricité, HAUTE TENSION, électronique, informatique, automatisme , Arduino, bref le BRICOLAGE , ...
Humeur : toujours cool
Date d'inscription : 31/01/2010

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par lereparateurdepc le Sam 30 Nov 2013 - 10:23

re,

Si je ne ma trompe pas, SZ tente de "convertir" une valeur System.Windows.Input.CommandBinding en System.Activities.Presentation.View.

De mémoire, il y a déjà eu un problème similaire mais pas avec les même types.

Mais pourquoi maintenant et pas avant ....
Si c'est une erreur de codage, pourquoi l'erreur ne s'est pas manifestée avant ?

PS : c'est pas génial un PC portable sans batterie ....

Cordialement,
Le réparateur de PC



Modérateur & Administrateur du forum
Merci de contacter les membres par MP ou mail que pour "urgences". Le forum est fait pour ça. Merci

@ Contact : franleboss@gmail.com  Smile
Arrow  Visitez mon site : désolé l'hébergeur à fermé Sad

Ma chaine tutube : https://www.youtube.com/channel/UC7iU59NNAHz-tW5wqcgONHA


avatar
Blackorion35
Je suis là tous les jours
Je suis là tous les jours

Masculin Nombre de messages : 2558
Age : 26
Localisation : Rouen
Emploi/loisirs : Dirigeant société informatique déclaré/Informaticien au CNED
Humeur : En forme !
Date d'inscription : 19/03/2013

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par Blackorion35 le Sam 30 Nov 2013 - 14:03

@lereparateurdepc a écrit:re,

Si je ne ma trompe pas, SZ tente de "convertir" une valeur System.Windows.Input.CommandBinding en System.Activities.Presentation.View.

De mémoire, il y a déjà eu un problème similaire mais pas avec les même types.

Mais pourquoi maintenant et pas avant ....
Si c'est une erreur de codage, pourquoi l'erreur ne s'est pas manifestée avant ?

PS : c'est pas génial un PC portable sans batterie ....

Cordialement,
Le réparateur de PC
Ha ok ben pour l'instant je code en VM Win 7 x64 le temps que ça se résout amusé
Quand à ma batterie : c'est 2 cellules sur 8 qui sont H.S. du coups elle tiens 20min maxi au lieu de 1h30 Razz  en faite elle me sert plus " d'onduleur " qu'autre chose Laughing



Le site officiel de notre société : http://algostep-company.fr
Notre WebOS "Rynna" en développement : http://rynnawebos.fr/login
Le WebOS "Zator" conçu pour le forum et ses membres dispo en test ici :
http://algostep-company.fr/WebOS-Zator-Test1/
---------------------------------------------------------
avatar
fandeonepiece2
Je suis là tous les jours
Je suis là tous les jours

Masculin Nombre de messages : 1804
Age : 16
Localisation : chez moi
Emploi/loisirs : Programmation H24
Humeur : massacrante... si je n'ai pas ma dose journalière de programmation
Date d'inscription : 14/09/2013

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par fandeonepiece2 le Lun 2 Déc 2013 - 17:18

bonjour,
je crois (hélas) que la seule solution à ton problème est de réinstaller Windows en formatant le disque dur vu que cela marche sur ta machine virtuel
cordialement



(ಠ_ಠ)


http://openclassrooms.com/forum/sujet/regie-publicitaire-drozor
avatar
lereparateurdepc


Masculin Nombre de messages : 5503
Age : 24
Localisation : Calvados
Emploi/loisirs : Electrotechnicien / électricité, HAUTE TENSION, électronique, informatique, automatisme , Arduino, bref le BRICOLAGE , ...
Humeur : toujours cool
Date d'inscription : 31/01/2010

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par lereparateurdepc le Lun 2 Déc 2013 - 19:53

re,

Il n'y as pas de lien entre cette erreur et l'OS excepté au travers le Framework.
De plus, réinstaller un OS n'est utile que pour des virus.
J'ai la même install de seven depuis 2009 (depuis sa sortie) et j'ai changé de config 2 fois même le HDD système y est passé !
Simplement une revalidation de l'activation de Windows et ça roule.

Donc, non, pas de réinstallation de Windows.

Je pense que les bugs de SZ 2012 sont liés aux diverses version d'OS et de MAJ.

Cordialement,
Le réparateur de PC



Modérateur & Administrateur du forum
Merci de contacter les membres par MP ou mail que pour "urgences". Le forum est fait pour ça. Merci

@ Contact : franleboss@gmail.com  Smile
Arrow  Visitez mon site : désolé l'hébergeur à fermé Sad

Ma chaine tutube : https://www.youtube.com/channel/UC7iU59NNAHz-tW5wqcgONHA


avatar
Blackorion35
Je suis là tous les jours
Je suis là tous les jours

Masculin Nombre de messages : 2558
Age : 26
Localisation : Rouen
Emploi/loisirs : Dirigeant société informatique déclaré/Informaticien au CNED
Humeur : En forme !
Date d'inscription : 19/03/2013

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par Blackorion35 le Lun 2 Déc 2013 - 19:59

C'est possible Lereparateurdepc Smile 
Je pense que je vais simplement devoir supprimer SZ + .NET 4.0 + .NET 3.5/2.0 et enlever toutes les clés du registre liés.
Si ça ne fonctionne toujours pas ce sera la solution de Fandeonepiece2 malheureusement : formatage du PC Sad Mais comme pour l'instant sa le fait avec un VM alors je vais pas risquer de formater mon PC qui contient plus de 300 logiciels et toutes les bases des logiciels de dev... Je vais d'abord sortir Mantrix Beta avant d'oser un formatage :/



Le site officiel de notre société : http://algostep-company.fr
Notre WebOS "Rynna" en développement : http://rynnawebos.fr/login
Le WebOS "Zator" conçu pour le forum et ses membres dispo en test ici :
http://algostep-company.fr/WebOS-Zator-Test1/
---------------------------------------------------------
avatar
fandeonepiece2
Je suis là tous les jours
Je suis là tous les jours

Masculin Nombre de messages : 1804
Age : 16
Localisation : chez moi
Emploi/loisirs : Programmation H24
Humeur : massacrante... si je n'ai pas ma dose journalière de programmation
Date d'inscription : 14/09/2013

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par fandeonepiece2 le Lun 2 Déc 2013 - 20:41

bonsoir,
en fait je crois que vu ton cas formater n'est pas une bonne idée
à un moment je trafiquai un peu mon Windows mais comme je n'était pas doué je devais le réinstaller au moins une fois par semaine:lol!: 
cordialement



(ಠ_ಠ)


http://openclassrooms.com/forum/sujet/regie-publicitaire-drozor
avatar
Blackorion35
Je suis là tous les jours
Je suis là tous les jours

Masculin Nombre de messages : 2558
Age : 26
Localisation : Rouen
Emploi/loisirs : Dirigeant société informatique déclaré/Informaticien au CNED
Humeur : En forme !
Date d'inscription : 19/03/2013

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par Blackorion35 le Mar 3 Déc 2013 - 0:17

Bonsoir Smile 

Trouvé le soucis Very Happy ! Et c'est pas une bonne nouvelle !! Evil or Very Mad Evil or Very Mad Suspect 

Malgré Avast Anti-Virus actif sur mon PC deux virus ce sont glissés dans la base même du Framework l'endommageant !

Preuve à l'appui après un scan minutieux : 



Si ce problème est arrivé chez vous pensez à voir si le fichier desktop.ini n'est pas corrompu ou remplacé par un virus ! Surtout que les bases GAC_32 et GAC-64 sont fusionnés sous Windows... donc non lisible tel quel (sauf avec l'astuce de compression/décompression sur une autre partition...).

Vous devrez donc, comme moi, effectué un Scan au démarrage pour pouvoir virer ces 2 virus No 

Après mon scan : SZ est bien reparti ! Very Happy 

Sujet résolu. Je clos le titre.



Le site officiel de notre société : http://algostep-company.fr
Notre WebOS "Rynna" en développement : http://rynnawebos.fr/login
Le WebOS "Zator" conçu pour le forum et ses membres dispo en test ici :
http://algostep-company.fr/WebOS-Zator-Test1/
---------------------------------------------------------
avatar
lereparateurdepc


Masculin Nombre de messages : 5503
Age : 24
Localisation : Calvados
Emploi/loisirs : Electrotechnicien / électricité, HAUTE TENSION, électronique, informatique, automatisme , Arduino, bref le BRICOLAGE , ...
Humeur : toujours cool
Date d'inscription : 31/01/2010

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par lereparateurdepc le Mar 3 Déc 2013 - 17:09

re,

tu est allé où pour choper ça ????? J'ai Avast et le pare-feu Windows 7 depuis 2009 et pas de soucis majeurs, en tout cas, pas de cette taille !

En quoi ce fichier Desktop.ini est-il un problème, ce n'est que pour modifier l'apparence du dossier .... Sauf si dans ce fichier on peut y glisser autre chose comme commandes mais bizarre.
Si tu as de nouveau ce problème, pense à moi en me donnant le contenu en format neutre (txt pas ex) pour voir Smile .

Cordialement,
Le réparateur de PC



Modérateur & Administrateur du forum
Merci de contacter les membres par MP ou mail que pour "urgences". Le forum est fait pour ça. Merci

@ Contact : franleboss@gmail.com  Smile
Arrow  Visitez mon site : désolé l'hébergeur à fermé Sad

Ma chaine tutube : https://www.youtube.com/channel/UC7iU59NNAHz-tW5wqcgONHA


avatar
Blackorion35
Je suis là tous les jours
Je suis là tous les jours

Masculin Nombre de messages : 2558
Age : 26
Localisation : Rouen
Emploi/loisirs : Dirigeant société informatique déclaré/Informaticien au CNED
Humeur : En forme !
Date d'inscription : 19/03/2013

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par Blackorion35 le Mar 3 Déc 2013 - 17:21

Ok si ça ce reproduit je te montrerai ça ^^



Le site officiel de notre société : http://algostep-company.fr
Notre WebOS "Rynna" en développement : http://rynnawebos.fr/login
Le WebOS "Zator" conçu pour le forum et ses membres dispo en test ici :
http://algostep-company.fr/WebOS-Zator-Test1/
---------------------------------------------------------
avatar
fandeonepiece2
Je suis là tous les jours
Je suis là tous les jours

Masculin Nombre de messages : 1804
Age : 16
Localisation : chez moi
Emploi/loisirs : Programmation H24
Humeur : massacrante... si je n'ai pas ma dose journalière de programmation
Date d'inscription : 14/09/2013

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par fandeonepiece2 le Mar 3 Déc 2013 - 18:43

bonjour,
Et un problème de plus résolus
cordialement



(ಠ_ಠ)


http://openclassrooms.com/forum/sujet/regie-publicitaire-drozor

Contenu sponsorisé

Re: Problème dans l'éditeur de SZ 2012 [RESOLU]

Message par Contenu sponsorisé


    La date/heure actuelle est Dim 20 Aoû 2017 - 15:15