Etienne BAUDOUX

Forum sur les projets de Etienne BAUDOUX


Gros problème, les icônes & images disparaissent. [Résolu]

avatar
WarDoG
Nouveau
Nouveau

Masculin Nombre de messages : 21
Date d'inscription : 03/03/2012

Gros problème, les icônes & images disparaissent. [Résolu] Empty Gros problème, les icônes & images disparaissent. [Résolu]

Message par WarDoG le Ven 19 Oct 2012 - 11:47

Yop,

Je suis entrain de faire une application avec SoftwareZator2011 mais j'ai un gros soucis :

Je mets un toolstrip, dans ce menu je souhaite mettre un icone à côté de chaque bouton, jusque là ça fonctionne.
J'enregistre mon application et je ferme le logiciel, et là j'ai des messages d'erreurs qui apparaissent :

http://image.noelshack.com/fichiers/2012/42/1350647149-sans-titre-1.png

J'appuie sur "ok" le logiciel se ferme, quand je le relance et que je charge mon projet les icônes de mes boutons ont disparu Sad
Que faut-il faire ?

Merci d'avance pour votre aide.


Dernière édition par WarDoG le Sam 20 Oct 2012 - 16:44, édité 1 fois
Admin
Admin
Administrateur
Administrateur

Masculin Nombre de messages : 1882
Age : 26
Localisation : Boulogne Billancourt(92100)(France)
Emploi/loisirs : Software Development Engineer
Date d'inscription : 24/01/2008

Gros problème, les icônes & images disparaissent. [Résolu] Empty Re: Gros problème, les icônes & images disparaissent. [Résolu]

Message par Admin le Ven 19 Oct 2012 - 11:55

Bonjour,

C'est un problème qu'il y a toujours eu dans SoftwareZator 2011. Ce problème n'est plus là dans la version 2012. Notez que la version 2011 n'est plus maintenant depuis environ 1 an Smile
Si vous souhaitez rester sous la version 2011, vous allez devoir ajouter vos images dans les ressources du projet (voir les Paramètres du projet), et utiliser les actions "Modifier une propriété d'un contrôle" pour les assigner au menu, dans une fonction liée à l'évènement Load de votre fenêtre (pas pratique je sais, mais c'est tout ce qu'on peut faire avec la version 2011 Neutral)

Bonne journée



Les 4 règles d'or du forum : Bonjour, Merci, Pas de SMS, Et un petit "[RESOLU]" dans le titre du sujet quand le problème est réglé. Wink

Etienne

Site internet : http://www.velersoftware.com
Twitter : http://twitter.com/VelerSoftware
avatar
WarDoG
Nouveau
Nouveau

Masculin Nombre de messages : 21
Date d'inscription : 03/03/2012

Gros problème, les icônes & images disparaissent. [Résolu] Empty Re: Gros problème, les icônes & images disparaissent. [Résolu]

Message par WarDoG le Ven 19 Oct 2012 - 13:12

Re,

Ok merci ! par contre j'ai pas tout compris, j'ai mis mes images dans les ressources du projet,

Clique droit "créer un événement" fonction "load" (sur ma fenêtre ou sur le menu ?)

Dans l'éditeur de fonction je mets "Modifier une propriété d'un contrôle" et là je suis paumé, je mets quoi dans "contrôle" "propriété" et "valeur" pour que ça fonctionne ?

merci encore.

lereparateurdepc
lereparateurdepc


Masculin Nombre de messages : 5601
Age : 26
Localisation : Calvados
Emploi/loisirs : Electrotechnicien / électricité, HAUTE TENSION, électronique, informatique, automatisme , Arduino, bref le BRICOLAGE , ...
Humeur : toujours cool
Date d'inscription : 31/01/2010

Gros problème, les icônes & images disparaissent. [Résolu] Empty Re: Gros problème, les icônes & images disparaissent. [Résolu]

Message par lereparateurdepc le Ven 19 Oct 2012 - 14:37

re ,

De préférence sur la Form mais peut imoporte ....

Cordialement ,
Le réparateur de PC



Modérateur & Administrateur du forum
Merci de contacter les membres par MP ou mail que pour "urgences". Le forum est fait pour ça. Merci

@ Contact : franleboss@gmail.com  Smile
Arrow  Visitez mon site : désolé l'hébergeur à fermé Sad

Ma chaine tutube : https://www.youtube.com/channel/UC7iU59NNAHz-tW5wqcgONHA


Gros problème, les icônes & images disparaissent. [Résolu] Wp_20110Gros problème, les icônes & images disparaissent. [Résolu] 10_32010Gros problème, les icônes & images disparaissent. [Résolu] Wp_20111Gros problème, les icônes & images disparaissent. [Résolu] 07_sig10
avatar
WarDoG
Nouveau
Nouveau

Masculin Nombre de messages : 21
Date d'inscription : 03/03/2012

Gros problème, les icônes & images disparaissent. [Résolu] Empty Re: Gros problème, les icônes & images disparaissent. [Résolu]

Message par WarDoG le Sam 20 Oct 2012 - 16:26

Re,

Ok et dans "Modifier une propriété d'un contrôle" qu'est ce que je mets dans "contrôle" "propriété" et "valeur" ?

Thx.
lereparateurdepc
lereparateurdepc


Masculin Nombre de messages : 5601
Age : 26
Localisation : Calvados
Emploi/loisirs : Electrotechnicien / électricité, HAUTE TENSION, électronique, informatique, automatisme , Arduino, bref le BRICOLAGE , ...
Humeur : toujours cool
Date d'inscription : 31/01/2010

Gros problème, les icônes & images disparaissent. [Résolu] Empty Re: Gros problème, les icônes & images disparaissent. [Résolu]

Message par lereparateurdepc le Sam 20 Oct 2012 - 16:32

re ,

Dans contrôle , le contrôle voulu ( bouton , Form , .... ) ,
La propriété Image ou celle utilisée ( celle que tu as modifiée dans les propriétées du contrôle ) ,
la valeur , fait comme si tu utilisais une variable et tu verra ton image en ressource ( tappe ce qui est entre "" : "%(" ) .

Tu doit avoir une action par contrôle !

PS :
Admin , dans votre message je n'ai pas très bien compris la phrase il doit manquer quesque chose :
Notez que la version 2011 n'est plus maintenant depuis environ 1 an

Cordialement ,
Le réparateur de PC



Modérateur & Administrateur du forum
Merci de contacter les membres par MP ou mail que pour "urgences". Le forum est fait pour ça. Merci

@ Contact : franleboss@gmail.com  Smile
Arrow  Visitez mon site : désolé l'hébergeur à fermé Sad

Ma chaine tutube : https://www.youtube.com/channel/UC7iU59NNAHz-tW5wqcgONHA


Gros problème, les icônes & images disparaissent. [Résolu] Wp_20110Gros problème, les icônes & images disparaissent. [Résolu] 10_32010Gros problème, les icônes & images disparaissent. [Résolu] Wp_20111Gros problème, les icônes & images disparaissent. [Résolu] 07_sig10
avatar
WarDoG
Nouveau
Nouveau

Masculin Nombre de messages : 21
Date d'inscription : 03/03/2012

Gros problème, les icônes & images disparaissent. [Résolu] Empty Re: Gros problème, les icônes & images disparaissent. [Résolu]

Message par WarDoG le Sam 20 Oct 2012 - 16:43

Ah ok merci, résolu. Very Happy

PS : Je pense qu'il a voulu dire que cette version n'était plus d'actualité. amusé
Admin
Admin
Administrateur
Administrateur

Masculin Nombre de messages : 1882
Age : 26
Localisation : Boulogne Billancourt(92100)(France)
Emploi/loisirs : Software Development Engineer
Date d'inscription : 24/01/2008

Gros problème, les icônes & images disparaissent. [Résolu] Empty Re: Gros problème, les icônes & images disparaissent. [Résolu]

Message par Admin le Sam 20 Oct 2012 - 16:55

Bonjour,

Oui pardon : plus "maintenue"



Les 4 règles d'or du forum : Bonjour, Merci, Pas de SMS, Et un petit "[RESOLU]" dans le titre du sujet quand le problème est réglé. Wink

Etienne

Site internet : http://www.velersoftware.com
Twitter : http://twitter.com/VelerSoftware

Contenu sponsorisé

Gros problème, les icônes & images disparaissent. [Résolu] Empty Re: Gros problème, les icônes & images disparaissent. [Résolu]

Message par Contenu sponsorisé


    La date/heure actuelle est Mar 16 Juil 2019 - 5:07