Etienne BAUDOUX

Forum sur les projets de Etienne BAUDOUX


[RESOLU] La valeur de l'argument "..." n'est pas valide

Saracax
Saracax
On s'intègre
On s'intègre

Masculin Nombre de messages : 246
Emploi/loisirs : Informatique
Date d'inscription : 30/08/2010

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Saracax le Jeu 26 Juil 2012 - 16:40

Bonjour,

J'ai actuellement un problème lorsque je clique sur un Bouton, un message s'affiche :

[RESOLU] La valeur de l'argument "..." n'est pas valide 418933201207261829

Avez-vous une idée d'où pourrait venir le problème ?

Merci d'avance,
Saracax.


Dernière édition par Saracax le Ven 27 Juil 2012 - 17:42, édité 2 fois



Saracax Production
Szman
Szman


Masculin Nombre de messages : 1255
Age : 19
Localisation : 76230 Bois-Guillaume
Emploi/loisirs : Code, musique, sport
Humeur : Toujours heureux évidemment!
Date d'inscription : 22/10/2011

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Szman le Jeu 26 Juil 2012 - 16:58

En lisant ce message, je suppose que tu as modifié une propriété value en mettant cette nouvelle valeur: 6 en vb ça donne (6)

Exemple, tu veux modifier la value d'une progressbar, le code sera:
Code:
ProgressBar1.Value = (6)

Voila, je crois que c'est dans ces eaux là (je n'ai jamais dit que la propriété value changée correspondait à une progressbar, c'était juste pour l'exemple.



Modérateur de la section SoftwareZator

SoftwareZator ah... quel outil formidable Very Happy Very Happy Very Happy 
Créer des logiciels en toute simplicité...c'est merveilleux study
Quand quelque chose ne va pas scratch: Le forum est là! Smile



Vous êtes sur un forum et il y a des règles à respecter: éviter les doubles-post et ne pas utiliser le langage sms. Merci de votre compréhension.


N'hésitez surtout pas à faire des tutoriels pour les autres.
Merci Very Happy



Venez voir ma chaîne Youtube: ChriisX !

Mon instagram: _chrischr


Bonjour Invité Smile
lereparateurdepc
lereparateurdepc


Masculin Nombre de messages : 5601
Age : 26
Localisation : Calvados
Emploi/loisirs : Electrotechnicien / électricité, HAUTE TENSION, électronique, informatique, automatisme , Arduino, bref le BRICOLAGE , ...
Humeur : toujours cool
Date d'inscription : 31/01/2010

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par lereparateurdepc le Jeu 26 Juil 2012 - 17:17

re ,

Normalement , pour une valeur Integer , il ne faut pas mettre de parenthèses .
ex :
ProgressBar1.Value = 6

MAIS SZ ne fait pas cette erreur ...
Si la propriété Value est modifiée par une variable ,
cette variable contient-elle : (6) ou simplement 6 ?

Cordialement ,
Le réparateur de PC



Modérateur & Administrateur du forum
Merci de contacter les membres par MP ou mail que pour "urgences". Le forum est fait pour ça. Merci

@ Contact : franleboss@gmail.com  Smile
Arrow  Visitez mon site : désolé l'hébergeur à fermé Sad

Ma chaine tutube : https://www.youtube.com/channel/UC7iU59NNAHz-tW5wqcgONHA


[RESOLU] La valeur de l'argument "..." n'est pas valide Wp_20110[RESOLU] La valeur de l'argument "..." n'est pas valide 10_32010[RESOLU] La valeur de l'argument "..." n'est pas valide Wp_20111[RESOLU] La valeur de l'argument "..." n'est pas valide 07_sig10
Szman
Szman


Masculin Nombre de messages : 1255
Age : 19
Localisation : 76230 Bois-Guillaume
Emploi/loisirs : Code, musique, sport
Humeur : Toujours heureux évidemment!
Date d'inscription : 22/10/2011

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Szman le Jeu 26 Juil 2012 - 17:25

Comme le message indique (6) je pense qu'il a écrit (6).



Modérateur de la section SoftwareZator

SoftwareZator ah... quel outil formidable Very Happy Very Happy Very Happy 
Créer des logiciels en toute simplicité...c'est merveilleux study
Quand quelque chose ne va pas scratch: Le forum est là! Smile



Vous êtes sur un forum et il y a des règles à respecter: éviter les doubles-post et ne pas utiliser le langage sms. Merci de votre compréhension.


N'hésitez surtout pas à faire des tutoriels pour les autres.
Merci Very Happy



Venez voir ma chaîne Youtube: ChriisX !

Mon instagram: _chrischr


Bonjour Invité Smile
Saracax
Saracax
On s'intègre
On s'intègre

Masculin Nombre de messages : 246
Emploi/loisirs : Informatique
Date d'inscription : 30/08/2010

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Saracax le Jeu 26 Juil 2012 - 19:00


Re,

Je ne sais pas vraiment d'où peux venir ce 6...
J'ai plusieurs actions contenant des " Générer un nombre entre 0 et 10 " et 0 et 15.
Je ne sais pas si celà pourrait venir d'ici. Neutral



Saracax Production
Szman
Szman


Masculin Nombre de messages : 1255
Age : 19
Localisation : 76230 Bois-Guillaume
Emploi/loisirs : Code, musique, sport
Humeur : Toujours heureux évidemment!
Date d'inscription : 22/10/2011

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Szman le Ven 27 Juil 2012 - 6:55

Re,

En lisant bien la dernière phrase, je pense que tu as créé un paramètre se nommant "value".
Sinon, regarde quand même dans les paramètres de ton projet si tu n'a pas un paramêtre nommé value. Je pense qu'il faut le supprimer.

ATTENTION!
Ce n'est qu'une simple proposition donc demande l'avis de quelqu'un qui si connait mieux que moi!



Modérateur de la section SoftwareZator

SoftwareZator ah... quel outil formidable Very Happy Very Happy Very Happy 
Créer des logiciels en toute simplicité...c'est merveilleux study
Quand quelque chose ne va pas scratch: Le forum est là! Smile



Vous êtes sur un forum et il y a des règles à respecter: éviter les doubles-post et ne pas utiliser le langage sms. Merci de votre compréhension.


N'hésitez surtout pas à faire des tutoriels pour les autres.
Merci Very Happy



Venez voir ma chaîne Youtube: ChriisX !

Mon instagram: _chrischr


Bonjour Invité Smile
Admin
Admin
Administrateur
Administrateur

Masculin Nombre de messages : 1882
Age : 27
Localisation : Boulogne Billancourt(92100)(France)
Emploi/loisirs : Software Development Engineer
Date d'inscription : 24/01/2008

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Admin le Ven 27 Juil 2012 - 8:20

Bonjour,

Essayez de démarrer votre programme en mode Déboguage (si vous êtes avec SoftwareZator 2012). SZ devrait vous afficher sur quelle action se produit l'erreur (si ça vient d'une action).



Les 4 règles d'or du forum : Bonjour, Merci, Pas de SMS, Et un petit "[RESOLU]" dans le titre du sujet quand le problème est réglé. Wink

Etienne

Site internet : http://www.velersoftware.com
Twitter : http://twitter.com/VelerSoftware
Saracax
Saracax
On s'intègre
On s'intègre

Masculin Nombre de messages : 246
Emploi/loisirs : Informatique
Date d'inscription : 30/08/2010

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Saracax le Ven 27 Juil 2012 - 9:18


Re,

J'utilise SoftwareZator 2011. Neutral



Saracax Production
Szman
Szman


Masculin Nombre de messages : 1255
Age : 19
Localisation : 76230 Bois-Guillaume
Emploi/loisirs : Code, musique, sport
Humeur : Toujours heureux évidemment!
Date d'inscription : 22/10/2011

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Szman le Ven 27 Juil 2012 - 9:25

C'est vraiment embétant... je me souviens plus, il n'y avait pas un système de déboguage sur SZ 2011 (le plus embêtant c'est que j'ai vu les screenshots et ça avait l'air super!).



Modérateur de la section SoftwareZator

SoftwareZator ah... quel outil formidable Very Happy Very Happy Very Happy 
Créer des logiciels en toute simplicité...c'est merveilleux study
Quand quelque chose ne va pas scratch: Le forum est là! Smile



Vous êtes sur un forum et il y a des règles à respecter: éviter les doubles-post et ne pas utiliser le langage sms. Merci de votre compréhension.


N'hésitez surtout pas à faire des tutoriels pour les autres.
Merci Very Happy



Venez voir ma chaîne Youtube: ChriisX !

Mon instagram: _chrischr


Bonjour Invité Smile
Saracax
Saracax
On s'intègre
On s'intègre

Masculin Nombre de messages : 246
Emploi/loisirs : Informatique
Date d'inscription : 30/08/2010

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Saracax le Ven 27 Juil 2012 - 9:51



Je vais regarder les dernière actions que j'ai insérées mais je ne vois pas vraiment laquelle pourrait entraîner celà..



Saracax Production
Saracax
Saracax
On s'intègre
On s'intègre

Masculin Nombre de messages : 246
Emploi/loisirs : Informatique
Date d'inscription : 30/08/2010

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Saracax le Ven 27 Juil 2012 - 9:55

Je n'ai aucune variable " Value " ..
Mais je modifie certaines valeurs de contrôles ... Certaines par des nombres compris entre 0 et 10 et 0 et 15.. Je ne sais pas si celà pourrait venir d'ici ? Neutral

Merci d'avance.
Saracax.



Saracax Production
Szman
Szman


Masculin Nombre de messages : 1255
Age : 19
Localisation : 76230 Bois-Guillaume
Emploi/loisirs : Code, musique, sport
Humeur : Toujours heureux évidemment!
Date d'inscription : 22/10/2011

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Szman le Ven 27 Juil 2012 - 9:58

Je crois savoir: tu as dit par des nombre entre 0 et 15 or 6 se trouve entre 0 et 15. D'où, tu as du modifier une propriété value de n'importe quel contrôle par (6) alors que tu aurai du écrire 6 et non (6).
Sinon je ne vois vraiment pas =(



Modérateur de la section SoftwareZator

SoftwareZator ah... quel outil formidable Very Happy Very Happy Very Happy 
Créer des logiciels en toute simplicité...c'est merveilleux study
Quand quelque chose ne va pas scratch: Le forum est là! Smile



Vous êtes sur un forum et il y a des règles à respecter: éviter les doubles-post et ne pas utiliser le langage sms. Merci de votre compréhension.


N'hésitez surtout pas à faire des tutoriels pour les autres.
Merci Very Happy



Venez voir ma chaîne Youtube: ChriisX !

Mon instagram: _chrischr


Bonjour Invité Smile
Saracax
Saracax
On s'intègre
On s'intègre

Masculin Nombre de messages : 246
Emploi/loisirs : Informatique
Date d'inscription : 30/08/2010

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Saracax le Ven 27 Juil 2012 - 10:49

C'est peut-être parce que j'ai enregistré un nombre dans une variable , or je veux faire (variable)++2 . Donc 'variable' peut être égale à 6 , soit (6)++2 .. Mais cela semble normal et ne devrait pas entraîner ce problème..?



Saracax Production
Szman
Szman


Masculin Nombre de messages : 1255
Age : 19
Localisation : 76230 Bois-Guillaume
Emploi/loisirs : Code, musique, sport
Humeur : Toujours heureux évidemment!
Date d'inscription : 22/10/2011

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Szman le Ven 27 Juil 2012 - 11:40

(6)++2 n'est pas un bon calcul soit ta variable contient (6) donc ce calcul ne devrait pas fonctionner, soit tu as carrément mis (6)++2 qui n'est pas un calcul correct (t'as qu'a essayer^^).

Petit rappel de mathématique (on est en vacances mais quand même^^) +2 = 2 donc change ton +2 en 2 et vérifie que ta variable contient bien 6 et non (6).

Enfin déja essaye le +2 en 2 et après si sa marche pas et ba vérifie que ta variable contient 6 et pas (6). Parce que ce n'est pas forcément le (6) qui dérange.
Autre chose: tu ne peux pas faire un calcul quand tu modifie une propriété d'un contrôle!

Ex:
Tu veux ajouter 2 à la value d'une progressbar. Dans la nouvelle valeur tu ne peux pas mettre 6+2 car cette valeur n'existe pas! Soit tu mets 8, soit tu effectue un calcul qui enregistre le résultat dans une variable comme ça la nouvelle valeur de la propriété value sera ta variable (autrement dit le résultat du calcul).

Voila. Informe moi du résultat.



Modérateur de la section SoftwareZator

SoftwareZator ah... quel outil formidable Very Happy Very Happy Very Happy 
Créer des logiciels en toute simplicité...c'est merveilleux study
Quand quelque chose ne va pas scratch: Le forum est là! Smile



Vous êtes sur un forum et il y a des règles à respecter: éviter les doubles-post et ne pas utiliser le langage sms. Merci de votre compréhension.


N'hésitez surtout pas à faire des tutoriels pour les autres.
Merci Very Happy



Venez voir ma chaîne Youtube: ChriisX !

Mon instagram: _chrischr


Bonjour Invité Smile
lereparateurdepc
lereparateurdepc


Masculin Nombre de messages : 5601
Age : 26
Localisation : Calvados
Emploi/loisirs : Electrotechnicien / électricité, HAUTE TENSION, électronique, informatique, automatisme , Arduino, bref le BRICOLAGE , ...
Humeur : toujours cool
Date d'inscription : 31/01/2010

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par lereparateurdepc le Ven 27 Juil 2012 - 15:56

re ,

Sous SZ 2011 , tu peut te faire un mini déboggeur .....
Place de haut en bas , devant chaque action , une à une un message quelquonque .
Si ton message s'affiche , avant l'erreur , c'est OK .
Pour faire plus simple : Place l'action Afficher un message devant ou après chaque actions .
Pas toutes en même temps mais action par actions .

PC : La propriété Value n'est pas présente sur TOUS les contrôles ....
Si tu peut poster ici ou en MP les codes utiliss ( plutôt VB )
sur les contrôles qui ont une propriété Value , je pense que celà m'aiderais .

Me*** , l'orage gronde ......

Cordialement ,
Le réparateur de PC



Modérateur & Administrateur du forum
Merci de contacter les membres par MP ou mail que pour "urgences". Le forum est fait pour ça. Merci

@ Contact : franleboss@gmail.com  Smile
Arrow  Visitez mon site : désolé l'hébergeur à fermé Sad

Ma chaine tutube : https://www.youtube.com/channel/UC7iU59NNAHz-tW5wqcgONHA


[RESOLU] La valeur de l'argument "..." n'est pas valide Wp_20110[RESOLU] La valeur de l'argument "..." n'est pas valide 10_32010[RESOLU] La valeur de l'argument "..." n'est pas valide Wp_20111[RESOLU] La valeur de l'argument "..." n'est pas valide 07_sig10
Saracax
Saracax
On s'intègre
On s'intègre

Masculin Nombre de messages : 246
Emploi/loisirs : Informatique
Date d'inscription : 30/08/2010

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Saracax le Ven 27 Juil 2012 - 17:42

Re,

Problème réglé ! J'avais une fonction " Modifier la propriété ".TextAlign " à la place de ".Text" Laughing

Le projet continue. Smile

Merci.

PS: Merci Lereparateurdepc pour cette astuce Wink

Cordialement,
Saracax



Saracax Production

Contenu sponsorisé

[RESOLU] La valeur de l'argument "..." n'est pas valide Empty Re: [RESOLU] La valeur de l'argument "..." n'est pas valide

Message par Contenu sponsorisé


    La date/heure actuelle est Dim 21 Juil 2019 - 5:16